Shop Mobile More Submit  Join Login
How to fix non-moving mmd parts/rigging tut by Ekkoberry How to fix non-moving mmd parts/rigging tut by Ekkoberry
So here you have a model you've put time and effort into editing.
you open it up in MMD to test it out....and then this happens.

Part of the hair decides it doesn't want to move.

Okay so I've come across this problem quite a few times when making a model. This problem ususally occurs when you delete off a bone that something was attached to- in my case here, the hair had pigtails with bones in 'em. And becasue I deleted the bones off, this happened.

Feel free to ask questions! but before you do, please read this tutorial first: [link]
this also helps explaing the little * thingy I put in near the end. that slider circled can change how attached the vertices are to the bone.
it's like percentages- 100/bright red is stuck completely, while 50/purple is only half stuck on.

Blue is not stuck on at all.

Omg please excuse my handwriting XDD

EDIT: I'm all for helping people, but this is a TUTORIAL. Not somewhere to post 'pls fix my model for me.' I can't handle all of these requests :iconlazycryplz:

I don't mind taking a look at people's models, but if you're asking me to do what is shown in the tutorial, then what's the point of even having this up here? try a few times more before asking me, please.
Add a Comment:
 

The Artist has requested Critique on this Artwork

Please sign up or login to post a critique.

:iconbubblyblobs:
BubblyBlobs Featured By Owner 1 day ago  New Deviant Hobbyist Digital Artist
I hope this works xD I have a model thats shirt doesn't go with her body.. but this looks like it works.
Reply
:iconyukixkumerai:
yukixkumerai Featured By Owner Jan 17, 2016  Student General Artist
my mmd models feet wont move, they just spin on their axis and cant lift off from the ground. The other parts of the legs wont really work either because of this. I really need to know how to fix this asap for a school project.
Reply
:iconninalightthekiller10:
NinaLightTheKiller10 Featured By Owner Jan 9, 2016
thanksss i have this problem c:
Reply
:iconflamealicorn:
FlameAlicorn Featured By Owner Jan 9, 2016  Hobbyist Filmographer
This tutorial really helped, especially when I couldn't get one of my model's cat ears to follow her head! But I was wondering if you can do a tutorial on certain parts of the model being invisible/not showing when it's in mmd. Because I have a model who looks like she has pupils in pmd, but when I put her in mmd her pupils seem to disappear.
Reply
:icondsgiant:
Dsgiant Featured By Owner Dec 30, 2015
This was super helpful, thank you very much! ^-^
Reply
:iconmitosuki-chan:
Mitosuki-Chan Featured By Owner Dec 13, 2015  Hobbyist General Artist
I can't find it anywhere and this seems the most relevant, but... Every time I loaded my model into mmd the skirt and vest would fly everywhere. I tried this with them and now they're just glitchy, not chaotic. Do you know how to fix it?
Reply
:iconmitosuki-chan:
Mitosuki-Chan Featured By Owner Dec 14, 2015  Hobbyist General Artist
Well, I fixed my problem with that (just saying "screw this model"), but my new model's skirt isn't moving with the legs.
Reply
:iconkaren300:
Karen300 Featured By Owner Nov 29, 2015  Student Artist
Thank you very very much!!
Reply
:iconchakkycharizard:
ChakkyCharizard Featured By Owner Nov 7, 2015  Hobbyist Digital Artist
Okay, so, how should I explain this...

When I rig the vertices to the proper bone at 0% weight, some other random bone automatically gets rigged to those same vertices at 100% weight. The hell?
Reply
:iconvelvezona-mmd:
Velvezona-mmd Featured By Owner Nov 4, 2015
It worked
The model moves and everything,but the accesorie doesn't move Marie (sad) 
Reply
:iconmmdmaxine:
MMDMaxine Featured By Owner Oct 10, 2015  Student General Artist
...I have no clue which bone I'm supposed to rig the head to..The body walks off without the head
Reply
:iconcryaotic1girl2013:
Cryaotic1girl2013 Featured By Owner Oct 6, 2015  Hobbyist General Artist
Right. It worked.
It's just not moving. 
Reply
:iconkwiu:
Kwiu Featured By Owner Oct 9, 2015  Hobbyist Digital Artist
Yup ;v; I clicked play.. and my model just.. walked off bald.
Reply
:iconcryaotic1girl2013:
Cryaotic1girl2013 Featured By Owner Oct 10, 2015  Hobbyist General Artist
Half of mine's body is still in the same spot, the arms only move it's extremely creepy.
Reply
:iconkwiu:
Kwiu Featured By Owner Oct 10, 2015  Hobbyist Digital Artist
Ahh, That sucks. I've looked all over the internet cough// not really.. and I haven't found anyone who has solved this problem. :v

I mean I do know what causes it, but I have  no idea how to fix it.

If you rig the models parts to the bone, the model parts will stay. If you unrig it it'll go back to the same glitchy crap you put together. ; - ; Ahh.. I might try to start over and move every joint, bone and some other stuff with the part carfully. I think that I might of screwed up the parts or so.
Reply
:iconcryaotic1girl2013:
Cryaotic1girl2013 Featured By Owner Oct 10, 2015  Hobbyist General Artist
Same.
Reply
:iconvalentinasart:
ValentinasArt Featured By Owner Sep 30, 2015  Hobbyist General Artist
Thanks, it helped me a lot! smol 
Reply
:iconanuthecat:
AnuTheCat Featured By Owner Sep 28, 2015  Student General Artist
So helpful TT-TT
Reply
:iconcalceownykka:
CalceownyKka Featured By Owner Sep 21, 2015  Hobbyist Digital Artist
Still doesn't work...
When i turn the "blue points" to red and test the model, ALL the parts that were black are not moving now. 
And i tried lots and lots of times ;-;
What do i have to do?? 
Reply
:iconklarisedem:
KlariseDem Featured By Owner Sep 2, 2015  Hobbyist Digital Artist
OH MY GOD THANK YOU SOOOOOOOOOOO MUCH ;___;
Reply
:icontegsmegamooze:
tegsmegamooze Featured By Owner Aug 20, 2015  Student General Artist
Will this work the same on PMX?
Reply
:iconteentitans01:
TeenTitans01 Featured By Owner Aug 10, 2015  Hobbyist General Artist
Mistress: Oh glob thank you so much <3 <3!!
Reply
:iconmonochrome-aki:
Monochrome-Aki Featured By Owner Aug 3, 2015
thank you so much!!!
this has helped me alot thank you thank you thank you! 
ive had this issue for so long and could never fix it 
so glad i know how to now
Reply
:iconxion-ino:
Xion-Ino Featured By Owner Aug 2, 2015
OMG thank you so much for this! <3 I was making a new model and learning how to delete physics, joints, and unnecessary bones, and I accidentally deleted a hair bone ^^' I also had wings that wouldn't move with my model, and now they do! <3 Thank youuuuuu! 
Reply
:iconlicamacabagdal:
licamacabagdal Featured By Owner Jul 17, 2015
Thank you very very much :D My model's skirt now works properly!
Reply
:iconpiegirl333:
piegirl333 Featured By Owner Jun 25, 2015  Hobbyist Digital Artist
My models arm keeps glitching through the sleeve, will this work for fixing that?
Reply
:iconrinnykagamine96:
RinnyKagamine96 Featured By Owner Jul 26, 2015
Sometimes, you just have to delete the entire arm so it's just the sleeve. Then, there won't even be an arm to glitch through it!
Reply
:iconpiegirl333:
piegirl333 Featured By Owner Jul 26, 2015  Hobbyist Digital Artist
Yeah I usually do that thanks =D
Reply
:iconshiaseki-suishou:
ShiaSeki-Suishou Featured By Owner May 20, 2015  Hobbyist General Artist
I am new with MMD... I'm trying to make a model and I have this problem. I followed the tutorial (and several other ones) step by step, but after it I still have the same problem...
After I select the bone I want the parts to move with, and all the parts, what should I do to save the new impostation? I tried almost everything T_T
Reply
:iconprettyskitty16:
PrettySkitty16 Featured By Owner May 9, 2015  Student General Artist
omfg thank you so so much I could not get my Kisshu model working right 
THANK YOU IM SO HAPPY
Reply
:iconkalosqueen214:
KalosQueen214 Featured By Owner May 8, 2015
i gotta question,i have a model whos shoe laces keep stretching toward the middle of the stage,i double checked the model i got it from and everything is the same ,there is no missing bones or anything,the model i got the shoes from was nakao luka, luka works fine but the shoelaces stretch on my model everything is in place on my model that is on luka but her shoe laces keep stretching toward the middle,i dunno what i did wrong,any ideas what might be going on? i tried this tutorial but it made the problem worst =(
Reply
:iconfallon234:
Fallon234 Featured By Owner Apr 25, 2015  Student General Artist
Holy crap it worked!!! THANK YOU VERY MUCH (ノ◕ヮ◕)ノ*:・゚✧
Reply
:iconinukagome95:
InuKagome95 Featured By Owner Apr 23, 2015  Hobbyist Digital Artist
Reply
:icongoldenpaperrose:
GoldenPaperRose Featured By Owner Apr 22, 2015  Hobbyist General Artist
I did it ! :D Oh my god thank you so much!
Reply
:iconriamuz:
RiamuZ Featured By Owner Apr 19, 2015  Hobbyist Traditional Artist
The head of my model isn't moving. Do I do this? :(
Reply
:iconfreedomgamerinse:
FreedomGamerINSE Featured By Owner Apr 2, 2015
Thanks, it worked ONLY in PMD editor, huh...Now I feel like I learned something by myself xD
Anyway Thank you very much, it helped a lot *ufff*
Take Care
~Krystian
Reply
:iconalalachan:
AlalaChan Featured By Owner Mar 27, 2015  Student Digital Artist
Thanks it worked!
Reply
:iconvinnyvirusdementos:
VinnyVirusDementos Featured By Owner Mar 23, 2015
I need help attaching a head.
Reply
:iconibmmdartandfandoms:
IbMMDartandfandoms Featured By Owner Mar 7, 2015  Student Digital Artist
what ver of PMD editor do y ou use..?
Reply
:iconekkoberry:
Ekkoberry Featured By Owner Mar 7, 2015  Student Digital Artist
I currently use PMX editor 0.2.2.2 (in japanese) but there's probably a later version out rn, I haven't downloaded anything mmd related since like mid 2014 : B
Reply
:iconibmmdartandfandoms:
IbMMDartandfandoms Featured By Owner Mar 7, 2015  Student Digital Artist
Okay cool. I just don't understand japanese, but I can just copy what you do in the tutorial. I have the latest version, but iw on't rig for shit. thank you!
Reply
:iconaoqi:
Aoqi Featured By Owner Feb 20, 2015  Hobbyist Digital Artist
This is working ! Thanks !
Reply
:icontheunknownmassacre6:
TheUnknownMASSACRE6 Featured By Owner Feb 20, 2015  Hobbyist Artist
How do I fix this thentheunknownmassacre6.deviantart…
Reply
:iconibmmdartandfandoms:
IbMMDartandfandoms Featured By Owner Jan 28, 2015  Student Digital Artist
Do you have a tutorial on bone making for hair? Hehe, I am having this problem, but it's because I deleted a needed bone and, well, need to remake it.
Reply
:iconmoonshadow0989:
Moonshadow0989 Featured By Owner Jan 14, 2015  Student General Artist
moonshadow0989.deviantart.com/…

I've done everything you said and it's still persisting as a problem. Could you please offer some guidance?
I think the main issue here is whenever I hold down shift to make the things red, it doesn't do anything. But if I don't hold down shift than the red bits show up fine. But everything was already at 100 and it's still doing this.
Reply
:iconekkoberry:
Ekkoberry Featured By Owner Jan 14, 2015  Student Digital Artist
pretty sure it'll be to do with bone connections then- check  the first hair bones and see if the parent bone is the head ;a;

not 100% sure tho
Reply
:iconmoonshadow0989:
Moonshadow0989 Featured By Owner Jan 14, 2015  Student General Artist
I don't think it is. :( I'll see what I can do, trying to get in touch with my MMD expert friend.
Reply
:iconthegeekachu:
TheGeekachu Featured By Owner Jan 9, 2015  Hobbyist General Artist
This is pretty much the closest tutorial to what I think I need to do, I'm trying to fix the glasses on a model which seem to be attached wrong (even though they're on his face, they seem to be attached to the center bone and nothing else so they only move with that and kinda float around separate from him if he's moving) What I want to do is unattach it from there and reattach it to the right place. Not sure if that'll work (if not do you know what I need to do?) but I haven't found anything that says how to unattach something. 
Reply
:icontheunknownmassacre6:
TheUnknownMASSACRE6 Featured By Owner Jan 1, 2015  Hobbyist Artist
I did everything

but it did the EXACT opposite
Reply
:iconthe-majestic-thong:
The-Majestic-Thong Featured By Owner Feb 17, 2015  Student General Artist
ovo did you color it in completely blue? if that's the case, then that's why. It has to be completely red on the bone you've selected.
I know that probably doesn't make a lick of sense, but ye.
Reply
Add a Comment:
 
×




Details

Submitted on
March 24, 2012
Image Size
2.2 MB
Resolution
1417×7000
Link
Thumb
Embed

Stats

Views
26,830 (1 today)
Favourites
621 (who?)
Comments
472
Downloads
306
×